Instalar MySQL 5.7 (y otras versiones) en Ubuntu

Yo, normalmente, trabajo a base de notas. Apunto todo tipo de snippets y procedimientos para que no se me olviden. De hecho, este blog ue estoy empezando es mi gran libro de notas para no perder nada.

la cuestión es que desde hace tiempo venia utilizando Elementary OS y hace unos días me he pasado a Ubuntu, a la versión 16, y el procedimiento que tenía para instalar MySQL me daba un error. Era el siguiente:

sudo apt-get install mysql-server php5-mysql

Y me lanzaba el siguiente error:

El paquete php5-mysql no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente

E: El paquete «php5-mysql» no tiene un candidato para la instalación

Así que rebuscando encontré la solución y me la apunto aquí.

Instalar MySQL 5.7

Para instalar MySQL 5.7 debemos actualizar nuestros repositorios y teclear estas lenas en la terminal

sudo apt-get install software-properties-common
sudo add-apt-repository -y ppa:ondrej/mysql-5.7
sudo apt-get update
sudo apt-get install mysql-server

Instalar MySQL 5.6

sudo apt-get install software-properties-common
sudo add-apt-repository -y ppa:ondrej/mysql-5.6
sudo apt-get update
sudo apt-get install mysql-server

Instalar MySQL 5.5

sudo apt-get install software-properties-common
sudo add-apt-repository -y ppa:ondrej/mysql-5.5
sudo apt-get update
sudo apt-get install mysql-server

Si veis que no es la opción más optima… ya sabeis, dejadme un comentario!